/ HomeLab

The HomeLab Mutation

I would be lying if I said that when I got interested in something, I don't take it to the extreme.


I've always had computers at home. And for at least the last 5 or 6 years, I've even had a full-time server running for things like Plex.

My HomeLab interest really started to gain speed in the first part of 2016. What started off as rewiring my home network to take advantage of future incoming Gigabit Internet, ended as a complete obsession sometime around June.

Now in December, it's safe to say that the obsession has gained an X-Gene and mutated into something quite a bit uglier.

The first real piece of gear was an R710 that I pulled from The Pile. After messing around with just potentially replacing my aging Ubuntu server with a more robust version (still running Ubuntu), I decided it was time to go full-tilt virtualization.

The first R710

For me, ESXi is a no brainer. ESXi is what I run in production, and this lab was eventually going to be used as a 3rd or 4th level disaster recovery for business.

At this point, this is a journey best told in pictures. First goes the R710, with dual E5520 CPUs and 32GB of RAM:

June 2016:

just one server

Of course, once you have a new server, it needs to be filled up with RAM and better CPUs! So out goes the 32GB and E5520s, and in goes 128GB and dual X5650 CPUs.

ram-r710
cpu-r710

July 2016

As the obsession steamrolls, one server isn't enough. So here comes another server (R210ii, E3-1220L + 32GB RAM), some external storage to hold all of the drives, as well as a UPS to keep it all alive:

r710+sa120x2+R210ii

September 2016

More steamrolling, and 10GbE becomes a necessity!

And the LackRack needs rails!

lackrack_build

And of course the R710 gets replaced with an R620 (which I eventually learned had a bad motherboard)

r620

October 2016

Unfortunately, the R620 had become unstable enough that it needed to be replaced.

Hello TS140 and T130! The T130 (E3-1230v5) was my main ESXi server and the TS140 (E3-1226v3) ran FreeNAS.

ts140
t130

November->December 2016

The final evolution

So as November and December rolled around, a few things became apparent. I was using a LOT of power. Upwards of 500 watts. And it was LOUD. The Seagate drives I was using required my drive enclosure fans to be set at medium->high to keep the drives in a safe range. This puts the setup firmly in low end of the "Jet Engine" range for noise level.

So I upgraded again.

A SYS-E300-8D for the file server,
SYS-e300-8D

a 5028D-TN4T for the virtualization server
5028D-TN4T

and a SYS-E200-9B for pfSense.

Finally, I picked up a DS2015xs for my main file storage. I don't have a picture of this installed as I only had it a few days.

Landing the Plane

Xeon D servers are fairly amazing. Low power consumption, a reasonable amount of computing umph, and almost silent. As of right now, my little HomeLab is pulling 180 watts under a moderate load. The lab is quiet enough now that the nearby furnace is louder than it.

The DS2015xs matched this paradigm nicely. Unfortunately, it also was a bit of a dud. With the underpowered CPU and what I believe is a bug in the software, the device was almost unusable for iSCSI, which is an absolute requirement for me. So I shipped it back to NewEgg and am looking at another solution for my main file storage.

I'll post an update when I figure out where I'm heading next!